peruuta
Näytä tulokset kohteelle 
Hae sen sijaan kohdetta 
Tarkoititko: 
57985 Jäsentä
161554 Kirjoitusta

Telia yhteisö on nyt myös laiteyhteisö

Lue lisää
Yhteistyössä OnePlus

Ubiquitin EdgeRouter ER-4



Uusi keskustelija
Rekisteröitynyt: ‎05-06-2017
Kirjoituksia: 8
1/16

Ubiquitin EdgeRouter ER-4

Hankin otsikon mukaisen reitittimen siinä toivossa että saisin enemmän irti telian kiinteistöliittymästä mikä päivittyi vdsl:stä ethernet tekniikkaan. ER-4 tuntuu kieltäytyvän kaikesta kommunikaatiosta Telian verkon kanssa. ER:n lisäksi yhteyttä on kokeiltu Airport Extremen kanssa millä liittymä toimii kuten pitääkin sekä suoraan kytkemällä tietokone, joka myös toimii.

 

Kokeilen seuraavanlaisia yhdistelmiä rajata tuota ongelmaa:

 

1. seinäpistoke (RJ45) -> Airport Extreme (NAT + DHCP) -> Wi-Fi -> Kone

   - toimii juuri niin kuin pitääkin

2. seinäpistoke -> Airport Extreme (NAT + DHCP) -> EdgeRouter (DHCP + NAT) -> Kone

   - toimii, kaikki kytkennät tehty kaapeleilla

3. seinäpistoke -> EdgeRouter (DHCP + NAT) -> Kone
   - ei toimi, jostain syystä ER ei suostu tunnistamaan tuota wan yhteyttä ollenkaan

 

 Alkuperäinen ajatus oli tietenkin saada ER reittimään/nat:maan liikenne seinäpistokkeesta ja käyttää airport:ia bridge moodissa ainoastaan tarjoilemaan langaton verkko.

 

 Kaikista ideoista ja ajatuksista kiitollinen, omat ideat alkaa olla aika loppu sen suhteen mikä tuossa voisi olla vikana. Onneksi tuon sentään saa palautta, mielellään näkisin sen toiminassa koska se tarjoaa ominaisuuksia mitä haluaisin ottaa käyttöön. Voiko tuossa olla ongelmana ihan vain yksinkertaisesti se että kyseinen laite ei vain sovellu tähän (telian) ympäristöön?

 

(liitteenä eth0 konfiguraation mikä osoittaa kohti wan:ia)

0 tykkäystä
15 vastausta
Asiantuntija
Asiantuntija
Rekisteröitynyt: ‎12-10-2018
Kirjoituksia: 187
2/16

Vs: Ubiquitin EdgeRouter ER-4


@lavernea  kirjoitti:

Voiko tuossa olla ongelmana ihan vain yksinkertaisesti se että kyseinen laite ei vain sovellu tähän (telian) ympäristöön?


Morjesta @lavernea ja Tervetuloa Yhteisöön!

 

Erittäin hyvät testit olet tehnyt. Voidaan todeta että se jää varmastikin siihen reitittimeen. Osaatko sanoa pitääkö reitittimelle määritellä asetukset erikseen, jotta sen saa toimintaan? Nykyisin laitteista löytyy jonkinlainen Quick Setup-minkä pyöräyttämällä sen saa toimintaa.

 

Vaikuttaisi, että jokin asetus sieltä puuttuisi koska se kuitenkin toimii tuon Airportin kautta. Saako reititin kuitenkin IP-osoitteen kun kytket sen suoraan seinäpistokkeeseen?

Telia Yhteisö on nyt myös Laiteyhteisö.jpg
0 tykkäystä
Uusi keskustelija
Rekisteröitynyt: ‎05-06-2017
Kirjoituksia: 8
3/16

Vs: Ubiquitin EdgeRouter ER-4

Olin aikeissa kkirjoittaa että ongelma näyttäisi rakenneen (ainakin tällä hetkellä Hymiö Onnellinen), eli ongelma oli automaattisen neuvottelun kanssa - ilmeisesti Telia ei tuo tuollaista auto-negotiation'ia yhteyttä muodostaessa, joten reitin ei pystynyt päättämään millä duplex-asetuksella toimitaan ja linja jäi "mykäksi" reitittimen mielestä.

 

Sain sen ratkaistua niin että asetuksena on nyt 100/Half duplex - koska 100/Full näyttäisi toimivan hivenen oudosti... eli 100/Half:lla tiedonsiirto on (down/up) ~90Mbits/~90Mbits kun 100/Full asetuksella päästään ainoastaa (down/up) ~20Mbits/~90Mbits, mistähän tälläinen voisi johtua?

 

Niin kuin tuossa ylempänä mainitsin niin reititin ei saanut minkäänlaista yhteyttä, sen mielestä tilanne oli sama kuin kaapelia ei olisi edes ollut kytkettynä, esim eth0 portin merkkivalo ei edes syttynyt.

 

Mutta tästä herää oikeastaan uusi kysymys - koska nyt noita duplex valintoja on 10/full, 10/half, 100/full ja 100/half, reititin on kuitenkin kykenevä gigabitin liityntään että miten mahtaa käydä jos haluaisin nostaa tuon oman liityntänopeuden siihen?

 

Tällä hetkellä vaihtoehdoissa ei ole 1000/full tai 1000/half vaihtoehtoja - reitittimen portti kyllä tukee tuollaista liityntänopeutta, esimerkiksi tuon airportin kanssa.

0 tykkäystä
Vakiokalustoa ☆☆
Rekisteröitynyt: ‎24-07-2015
Kirjoituksia: 386
4/16

Vs: Ubiquitin EdgeRouter ER-4

Ei ole kokemusta ER4:stä, itsellä on ERpro8, joka on räkkimalli.

 

Mutta jos se toimii yhtään samalla tavalla, niin heti paketista purettuna laite on configuroimaton, joka tarkoittaa ettei se reititä mitään, koska et ole kertonut sille miten sen haluat toimivan. Pelkkä porttien käsin conffaaminen ei vielä auta mitään, koska sieltä puuttuu reititykset, palomuurin perusasetukset ja aivan kaikki.

 

Nämä saa kuntoon WebUI:sta löytyvällä wizardilla. Ainakn ERpro8:ssa wizardit ovat kaikkein oikeimmanpuolinen välilehti. Valitse sieltä esim. WAN+2LAN yms. tai miten sen nyt haluatkaan toimivan ja se wizardi tekee sulle sinne toimivan NAT-perusconffin ja vasta sen jälkeen voit säädellä loput jutut kuten haluat. Wizardi tarvitsee siis ajaa vain kerran, ellet sitten nollaa sitä tehdasresetillä, jota ei EdgeRouterin tapauksessa tarvitse tehdä ikinä.

 

Myös WLAN kannattaa laittaa EdgeRouterin taakse, tarvittaessa voit perustaa sille oman erillisen LANin jos jostain syystä et halua että WLAN ja LAN laitteet toimivat samassa sisäverkossa. Mielestäni ei ole mitään järkeä käyttää huonompaa reititintä mihinkään, kun olet kerran EdgeRouterin hankkinut. Se on ainoita reitittimiä, joka toimii esim. gigabitin kuituliittymässä täydellä nopeudella. Just eilen itse asiassa mittailin omaa liittymää kun tulin jälleen siihen tulokseen ettei yhdellä koneella ajettu speedtest edes riitä, vaan speedtest pitää ajaa kahdella koneella yhtä aikaa ja katsoa sitten tulos EdgeRouterin WebUI:sta. Siellä luki 988 Mbit/sek, samallla kun EdgeRouterin CPU-loadi ei juurikaan nouse, joten ei valittamista.

 

Muutenkin jos arvostaa toimivuutta, niin ainakaan ERpro8:a ei tarvitse resetoida koskaan eikä varsinkaan mitään hölmöjä tehdasasetusten palautteluja yms. mitä valkoisille muovirasioille pitää olla vähän väliä tekemässä.

0 tykkäystä
Vakiokalustoa ☆☆
Rekisteröitynyt: ‎24-07-2015
Kirjoituksia: 386
5/16

Vs: Ubiquitin EdgeRouter ER-4


@lavernea  kirjoitti:

Niin kuin tuossa ylempänä mainitsin niin reititin ei saanut minkäänlaista yhteyttä, sen mielestä tilanne oli sama kuin kaapelia ei olisi edes ollut kytkettynä, esim eth0 portin merkkivalo ei edes syttynyt.

 


Ahaa, sulla onkin siis linkkiongelma, eikä conffausjuttu. Tämä kuulostaa nyt siltä että sulla on vääränlainen kaapeli, esimerkiksi sellainen missä on vain 4 johdinta kytkettynä (100 Mbit ethernet-kaapeli) tai sitten seinärasioissa on jossain kytkettynä vain 4 tai sitten on vialliset kytkennät. Gigabit ethernet vaatii aina kaikki parit eli 8 johdinta pitää olla kytkettynä päästä päähän. Se ei automaattisesti pudota nopeutta 100 Mbittiin jos vain osa johtimista on kytkettynä, vaan linkki jää kokonaan nousematta (eli portin valot eivät syty).

0 tykkäystä
Uusi keskustelija
Rekisteröitynyt: ‎05-06-2017
Kirjoituksia: 8
6/16

Vs: Ubiquitin EdgeRouter ER-4

Tämä oli tiedossa jo ostohetkellä että todennäköisesti mikään ei toimi one-click-and-done. Porttien, palomuurin ja reititysten konffaus onnistui ihan niin kuin pitikin. Käytin itseasiassa WAN2LAN2 wizardia tuohon alkuun ja säädin sen jälkeen muut kohdalleen ja testasin että ne toimivat tuolla airport & er kombinaatiolla.

 

Nyt kun sain sen toimimaan vaihtamalla tuon auto-negotiation'n 100/Half duplex:iin, ER vaikuttaa oikeasti todella hyvältä ja nopealta reitittimeltä - ero tuollaiseen kalliiseen kuluttajalaitteeseen on aika huima.

 

Tuossa nyt vielä jää vähän mietityttämään tuo yhteyden muodostaminen mihin viittasin aiemmassa omassa vastauksessa - etenkin kun olin ajatellut nostaa tuota liittymänopeutta jossain vaiheessa.

 


@SINAD  kirjoitti:

 

Muutenkin jos arvostaa toimivuutta, niin ainakaan ERpro8:a ei tarvitse resetoida koskaan eikä varsinkaan mitään hölmöjä tehdasasetusten palautteluja yms. mitä valkoisille muovirasioille pitää olla vähän väliä tekemässä.


Valkoiset muovilaatikot en niin testattu, airport olkoon ainoa poikkeus tähän mennessä - sen takia päädyin tuohon, se jatkuva säätäminen ei ole se mitä haluan internetin eteen tehdä.

0 tykkäystä
Uusi keskustelija
Rekisteröitynyt: ‎05-06-2017
Kirjoituksia: 8
7/16

Vs: Ubiquitin EdgeRouter ER-4


Ahaa, sulla onkin siis linkkiongelma, eikä conffausjuttu. Tämä kuulostaa nyt siltä että sulla on vääränlainen kaapeli, esimerkiksi sellainen missä on vain 4 johdinta kytkettynä (100 Mbit ethernet-kaapeli) tai sitten seinärasioissa on jossain kytkettynä vain 4 tai sitten on vialliset kytkennät. Gigabit ethernet vaatii aina kaikki parit eli 8 johdinta pitää olla kytkettynä päästä päähän. Se ei automaattisesti pudota nopeutta 100 Mbittiin jos vain osa johtimista on kytkettynä, vaan linkki jää kokonaan nousematta (eli portin valot eivät syty).


Olin katsovinani että tuossa kaapelissa olisi kaikki 8 kytketty - mutta sitten tuolla sähkökaapissa näyttäisi olevan pari kappaletta kaapeleita mistä on vaikea nähdä montako johdinta niissä on, mutta niissä lukee "... cable 4 pair" mikä viittaisi siihen että niissäkin olisi kaikki kytketty. Seinärasioiden kytkennöistä en osaa sanoa, jos näin on niin sitten on säästetty ihmeellisessä paikassa Hymiö Yllättynyt

 

Kiitos Hymiö Onnellinen, tämä on kuitenkin suht helppo varmistaa että ongelma ei ole ainakaan noissa kaapeleissa.

0 tykkäystä
Vakiokalustoa ☆☆
Rekisteröitynyt: ‎24-07-2015
Kirjoituksia: 386
8/16

Vs: Ubiquitin EdgeRouter ER-4


@lavernea  kirjoitti:

Tämä oli tiedossa jo ostohetkellä että todennäköisesti mikään ei toimi one-click-and-done. Porttien, palomuurin ja reititysten konffaus onnistui ihan niin kuin pitikin. Käytin itseasiassa WAN2LAN2 wizardia tuohon alkuun ja säädin sen jälkeen muut kohdalleen ja testasin että ne toimivat tuolla airport & er kombinaatiolla.

 

Nyt kun sain sen toimimaan vaihtamalla tuon auto-negotiation'n 100/Half duplex:iin, ER vaikuttaa oikeasti todella hyvältä ja nopealta reitittimeltä - ero tuollaiseen kalliiseen kuluttajalaitteeseen on aika huima.

 

Tuossa nyt vielä jää vähän mietityttämään tuo yhteyden muodostaminen mihin viittasin aiemmassa omassa vastauksessa - etenkin kun olin ajatellut nostaa tuota liittymänopeutta jossain vaiheessa.

 


Wizardin ajamisen jälkeen pitäisi tosiaan alkaa reitittää, kun iskee vaan piuhat kiinni... Esim. WAN-portin asetuksiin ei tarvitse kajota, mutta LAN-portit voit toki säädellä mielesi mukaan

 

Liittymään valittu nopeusluokka ei kyllä mielestäni saisi vaikuttaa mitään Ethernet-linkin nopeuteen. Koska jos siellä on gigabitin kytkin talojakamossa, niin autonegotiation tilassa siihen neuvotellaan aina gigabitin yhteys, varsinainen liittymän nopeus voidaan rajoittaa sitten erikseenkin. Mutta sellainen vaatii aina 4 paria eli 8 johdinta. Jos yksikin on jostain poikki, niin linkki ei nouse lainkaan. Mutta jos liität verkkoon sellaisen laitteen jossa on vain 100 Mbit Ethernet, niin silloin linkki nousee, koska 2 toimivaa paria (4 johdinta) riittää.

 

Laitteet osaavat siis tunnistaa, millainen laite linkin toisessa päässä on ja autonegotiation ideana on muodostaa nopein mahdollinen yhteys. Autonegotiation lähtee aina siitä olettamasta, että välissä on EHJÄT kaapelit, eikä nopeutta lähdetä pudottamaan ADSL/VDSL tyyliin siten, että saadaan huonompi linkki aikaan väkisin.

 

Airport ei ole mulle laittena lainkaan tuttu, mutta jos siinä sattuisi olemaan pelkästään 100 Mbit portti, niin se voisi selittää sen miksi se toimii mutta ER ei toimi muuten kuin säätämällä nopeus käsin.

 

Sellaistakin voit kokeilla että jos saat jostain käsiisi gigabit-kytkimen (sellaiselle tulee sulle tarvetta verkon rakentamisessa joka tapauksessa, jos haluat enemmän laitteita verkkoon) niin testaapa, muodostuuko seinärasiasta yhteyttä siihen kytkimeen. Ja sitten siitä kytkimeltä vasta ER:lle. Tällöin sen kytkimen perässä olisi suoraan WAN-verkkoa tarjolla, jos tarvitset esimerkiksi useampaa julkista IP:tä reitittimen ohi jne.

 

Jos linkki ei nouse myöskään gigabit-kytkimellä oikein, niin suosittelisin tarkistamaan rasiat ja kaapeloinnit.

0 tykkäystä
Uusi keskustelija
Rekisteröitynyt: ‎05-06-2017
Kirjoituksia: 8
9/16

Vs: Ubiquitin EdgeRouter ER-4


@SINAD  kirjoitti:


Wizardin ajamisen jälkeen pitäisi tosiaan alkaa reitittää, kun iskee vaan piuhat kiinni... Esim. WAN-portin asetuksiin ei tarvitse kajota, mutta LAN-portit voit toki säädellä mielesi mukaan


 Sitä jäin kanssa ihmettelemään, eikä siihen oikein tuntunut löytyvän ratkaisua - sitkeällä googlamisella löysin sitten postauksen missä oli samanlainen ongelma.

 


Liittymään valittu nopeusluokka ei kyllä mielestäni saisi vaikuttaa mitään Ethernet-linkin nopeuteen. Koska jos siellä on gigabitin kytkin talojakamossa, niin autonegotiation tilassa siihen neuvotellaan aina gigabitin yhteys, varsinainen liittymän nopeus voidaan rajoittaa sitten erikseenkin. Mutta sellainen vaatii aina 4 paria eli 8 johdinta. Jos yksikin on jostain poikki, niin linkki ei nouse lainkaan. Mutta jos liität verkkoon sellaisen laitteen jossa on vain 100 Mbit Ethernet, niin silloin linkki nousee, koska 2 toimivaa paria (4 johdinta) riittää.

 

  Täytyy yrittää saada isännöitsijältä tiedot mitä tuolla talojakamossa oikein on ja millaiset nuo seinään tehdyt kaapeloinnit ovat, tuntuu tuo vähän uskomattomalta että autonegotaatio ei toimi niin kuin pitäisi.

 


Airport ei ole mulle laittena lainkaan tuttu, mutta jos siinä sattuisi olemaan pelkästään 100 Mbit portti, niin se voisi selittää sen miksi se toimii mutta ER ei toimi muuten kuin säätämällä nopeus käsin.

 Airport'ssa on 1Gbit portit, en muistanut katsoa miten se ER käyttäytyy silloin kun se oli kytkettynä airportiin, äkkiähän sen testaa

 


Sellaistakin voit kokeilla että jos saat jostain käsiisi gigabit-kytkimen (sellaiselle tulee sulle tarvetta verkon rakentamisessa joka tapauksessa, jos haluat enemmän laitteita verkkoon) niin testaapa, muodostuuko seinärasiasta yhteyttä siihen kytkimeen. Ja sitten siitä kytkimeltä vasta ER:lle. Tällöin sen kytkimen perässä olisi suoraan WAN-verkkoa tarjolla, jos tarvitset esimerkiksi useampaa julkista IP:tä reitittimen ohi jne.

 Se tulee tuossa vastaan kunhan saan mm. mediaserverin kasaan, nyt on jo kaikki vapaat portit käytössä - katson vielä nuo kaapelikin läpi ja varmista että ne kaikki ovat noita 4-parisia

0 tykkäystä
Highlighted
Vakiokalustoa ☆☆
Rekisteröitynyt: ‎24-07-2015
Kirjoituksia: 386
10/16

Vs: Ubiquitin EdgeRouter ER-4

Onpas sitten jännä, jos Airport kuitenkin kättelee gigaisena. Joskus on ollut kyllä juttuja yhteensopivuusongelmista autonegotiation-tilassa, mutta koskee lähinnä ikivanhoja verkkoja, ei gigaisia. Lieneeköhän siellä sitten erityisen pitkä kaapelointi talojakamolle, että olisi niin rajoilla ettei ER-4:llä enää linkki nousekaan. Jos kerran muutkin valittaneet moista? Teoreettinen maksimipituus gigabitin linkeille on 100 metriä, mutta se tietysti edellyttää että kaapelointi on kunnollista. Itsellä ei ole lainkaan kokemusta EdgeRouterin suhtautumisesta erittäin pitkiin linkkeihin, koska käytännössä kaikki reitittimelle tulevat kaapelit ovat mulla sellaisia 20 cm. pätkiä siellä 19" räkissä. Eihän se tietysti olisi mahdotonta, jos Ubiquitin valitsema PHY-piiri ei olisi kykenevä yhtä pitkiin linkkeihin kuin mihin Airportin PHY pystyy.

 

Hallittava kytkin auttaisi nyt kyllä paljon, jos saisi edes lainaksi jostain.. Niillä voi ajaa diagnostiikkaa porteille ja nähdä, mikä siellä on vikana. Jos on esimerkiksi pareja väärin kytkettynä, sen näkee. Muutenkin ainakin tunnettujen valmistajien kytkinten (Cisco yms) tulisi kyllä noutattaa Ethernet-standardeja hyvin tiukasti, jolloin pitkätkin linkit pitäisi toimia häiriöittä.

 

Tässä esimerkkinä ajoin omalta keskuskytkimeltä (Cisco SG300-28P) diagnostiikan tyhjään rasiaan. Kytkin osaa mm. mitata kuinka pitkä kaapeli siinä on, vaikka toisessa päässä ei ole mitään kytkettynä:

cable-test.png

0 tykkäystä