Yhteisö

Lueskele, kysy neuvoa, keskustele, opi uutta ja liity mukaan!
Jäseniä 60334
Kirjoituksia 166070

Soneran 6rd IPv6 & sen toteutus OpenWRT:ssä



Highlighted
Kommentaattori
Rekisteröitynyt: ‎27-12-2014
Kirjoituksia: 59
1/9

Soneran 6rd IPv6 & sen toteutus OpenWRT:ssä

Hei!

 

Olen yrittänyt nyt laittaa sitä toimimaan OpenWRT reittimessä, mutta liikenne ei mene läpi siitä. Koneet saa kyllä IPv6 osoitteet.

 

Onko mitään tietoa miten saisi korjattua?

 

OpenWRT confit:

 

ifconfig:

root@OpenWrt:~# ifconfig
6rd-wan6  Link encap:IPv6-in-IPv4
          inet6 addr: ::88.195.194.203/128 Scope:Compat
          inet6 addr: 2001:2003:c3c2:cbcb::1/56 Scope:Global
          UP RUNNING NOARP  MTU:1280  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:101 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:7404 (7.2 KiB)

br-lan    Link encap:Ethernet  HWaddr 64:66:B3:FA:1D:80
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6666:b3ff:fefa:1d80/64 Scope:Link
          inet6 addr: 2001:2003:c3c2:cbcb::1/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:23235 errors:0 dropped:0 overruns:0 frame:0
          TX packets:29349 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2088398 (1.9 MiB)  TX bytes:34122364 (32.5 MiB)

br-wan    Link encap:Ethernet  HWaddr 64:66:B3:FA:1D:80
          inet6 addr: fe80::6666:b3ff:fefa:1d80/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:181 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:57870 (56.5 KiB)

eth0      Link encap:Ethernet  HWaddr 64:66:B3:FA:1D:80
          inet6 addr: fe80::6666:b3ff:fefa:1d80/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:25699 errors:0 dropped:113 overruns:3366 frame:0
          TX packets:29535 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2880703 (2.7 MiB)  TX bytes:34298489 (32.7 MiB)
          Interrupt:4

eth0.1    Link encap:Ethernet  HWaddr 64:66:B3:FA:1D:80
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:24480 errors:0 dropped:0 overruns:0 frame:0
          TX packets:29317 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2311391 (2.2 MiB)  TX bytes:34119084 (32.5 MiB)

eth0.2    Link encap:Ethernet  HWaddr 64:66:B3:FA:1D:80
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:178 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:57412 (56.0 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:152 errors:0 dropped:0 overruns:0 frame:0
          TX packets:152 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:17235 (16.8 KiB)  TX bytes:17235 (16.8 KiB)

wlan0     Link encap:Ethernet  HWaddr 64:66:B3:FA:1D:80
          inet addr:88.195.194.203  Bcast:88.195.207.255  Mask:255.255.240.0
          inet6 addr: fe80::6666:b3ff:fefa:1d80/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:32288 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20573 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:34204254 (32.6 MiB)  TX bytes:2454864 (2.3 MiB)

wlan0-1   Link encap:Ethernet  HWaddr 66:66:B3:FA:1D:80
          inet6 addr: fe80::6466:b3ff:fefa:1d80/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:744 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:95389 (93.1 KiB)

/etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option type 'bridge'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 5t'

config interface 'wwan'
        option proto 'dhcp'

config interface 'wan6'
        option proto '6rd'
        option peeraddr '80.221.111.254'
        option ip6prefix '2001:2003:C3C2:CB00::'
        option ip6prefixlen '56'
        option ip4prefixlen '24'
        option adv_subnet '1'
        option adv_interface 'lan'

/etc/config/radvd:

config interface
        option interface        'lan'
        option AdvSendAdvert    1
        option AdvManagedFlag   0
        option AdvOtherConfigFlag 0
        option ignore           0

config prefix
        option interface        'lan'
        option AdvOnLink        1
        option AdvAutonomous    1
        option AdvRouterAddr    0
        option Base6to4Interface        'eth1'
        option ignore           1

config route
        option interface        'lan'
        list prefix             ''
        option ignore           1

config rdnss
        option interface        'lan'
        # If not specified, the link-local address of the interface is used
        list addr               ''
        option ignore           1

config dnssl
        option interface        'lan'
        list suffix             ''
        option ignore           1

ip -6 r s:

default from :: via ::80.221.111.254 dev 6rd-wan6  proto static  metric 4096
default from 2001:2003:c3c2:cbcb::/64 via ::80.221.111.254 dev 6rd-wan6  proto static  metric 4096
default from 2001:2003:c3c2:cb00::/56 via ::80.221.111.254 dev 6rd-wan6  proto static  metric 4096
::/96 dev 6rd-wan6  metric 256
2001:2003:c3c2:cbcb::/64 dev br-lan  proto static  metric 1024
unreachable 2001:2003:c3c2:cbcb::/64 dev lo  proto static  metric 2147483647  error -128
2001:2003:c3c2:cb00::/56 dev 6rd-wan6  proto kernel  metric 256
fe80::/64 dev eth0  proto kernel  metric 256
fe80::/64 dev br-lan  proto kernel  metric 256
fe80::/64 dev br-wan  proto kernel  metric 256
fe80::/64 dev wlan0  proto kernel  metric 256
fe80::/64 dev wlan0-1  proto kernel  metric 256

Windows koneen route:

C:\Users\Sami>route print -6
===========================================================================
Interface List
 19...00 ff 4d 2a b7 9e ......TAP Adapter OAS NDIS 6.0
 21...00 ff ba 5b d2 9d ......TAP-Windows Adapter V9 #2
 20...00 ff 9e 78 85 ff ......TAP-Windows Adapter V9
  6...9c d2 1e f5 62 b2 ......Bluetooth Device (Personal Area Network)
  5...9e d2 1e f5 62 b1 ......Microsoft Wi-Fi Direct Virtual Adapter
  4...9c d2 1e f5 62 b1 ......Broadcom 802.11n Network Adapter
  3...20 25 64 87 61 e9 ......Qualcomm Atheros AR8172/8176/8178 PCI-E Fast Ether
net Controller (NDIS 6.30)
  1...........................Software Loopback Interface 1
 45...00 00 00 00 00 00 00 e0 Microsoft ISATAP -sovitin #3
  8...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface
===========================================================================

IPv6 Route Table
===========================================================================
Active Routes:
 If Metric Network Destination      Gateway
  3    276 ::/0                     fe80::6666:b3ff:fefa:1d80
  1    306 ::1/128                  On-link
  8    306 2001::/32                On-link
  8    306 2001:0:9d38:90d7:38d0:19dc:a73c:3d34/128
                                    On-link
  3    276 2001:2003:c3c2:cbcb::/64 On-link
  3    276 2001:2003:c3c2:cbcb::693/128
                                    On-link
  3    276 2001:2003:c3c2:cbcb:198e:c1b0:610c:bf46/128
                                    On-link
  3    276 2001:2003:c3c2:cbcb:8484:9e23:5594:11c6/128
                                    On-link
  3    276 fe80::/64                On-link
  8    306 fe80::/64                On-link
  3    276 fe80::198e:c1b0:610c:bf46/128
                                    On-link
  8    306 fe80::38d0:19dc:a73c:3d34/128
                                    On-link
  1    306 ff00::/8                 On-link
  3    276 ff00::/8                 On-link
  8    306 ff00::/8                 On-link
===========================================================================
Persistent Routes:
  None

ipconfig:

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . : lan
   IPv6 Address. . . . . . . . . . . : 2001:2003:c3c2:cbcb::693
   Temporary IPv6 Address. . . . . . : 2001:2003:c3c2:cbcb:8484:9e23:5594:11c6
   Link-local IPv6 Address . . . . . : fe80::198e:c1b0:610c:bf46%3
   IPv4 Address. . . . . . . . . . . : 192.168.1.50
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : fe80::6666:b3ff:fefa:1d80%3
                                       192.168.1.1
0 tykkäystä
8 vastausta
Highlighted
Kunniajäsen
Rekisteröitynyt: ‎26-12-2013
Kirjoituksia: 4 399
2/9

Vs: Soneran 6rd IPv6 & sen toteutus OpenWRT:ssä

Tuotas sulla väärä prefix

 

 

root@OpenWrt:~# ifconfig
6rd-wan6  Link encap:IPv6-in-IPv4
          inet6 addr: ::88.195.194.203/128 Scope:Compat
          inet6 addr: 2001:2003:c3c2:cbcb::1/56 Scope:Global
          UP RUNNING NOARP  MTU:1280  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:101 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:7404 (7.2 KiB)

 

 

-> Pitäisi olla Sonera 6rd:ssä /64 prefixi... eli 

2001:2003:c3c2:cbcb::1/64

 

 Itselläni tuotti ongelmia tämä reititys... koska ei molemmissa interfacessavoi olla sama prefix tai osoitte. 

 

br-lan    Link encap:Ethernet  HWaddr 64:66:B3:FA:1D:80
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6666:b3ff:fefa:1d80/64 Scope:Link
          inet6 addr: 2001:2003:c3c2:cbcb::1/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:23235 errors:0 dropped:0 overruns:0 frame:0
          TX packets:29349 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2088398 (1.9 MiB)  TX bytes:34122364 (32.5 MiB)

Tällä hetkellä minulla toimii ainakin omassa Linuxissani /64 prefixillä osoitteisto 6rd interfacessa ja lanissa /65 prefix...  

 

Esim jos laittaisit /65 prefixin  br-lan interfaceen

 

 

2001:2003:c3c2:cbcb:a::1/65

 

Työasemille sitten esim näin

 

2001:2003:c3c2:cbcb::2/65

ja gw on tietenkin. Kokeile toimiiko näin. Dhcpv6 kylläkin haluaa tuon /64 prefixin verkon että sitten pitää olla staattiset. Itse en ole keksinyt parempaa ratkaisua.

 

 

0 tykkäystä
Highlighted
Kommentaattori
Rekisteröitynyt: ‎27-12-2014
Kirjoituksia: 59
3/9

Vs: Soneran 6rd IPv6 & sen toteutus OpenWRT:ssä


@olkitu kirjoitti:

Tuotas sulla väärä prefix

 

 

root@OpenWrt:~# ifconfig
6rd-wan6  Link encap:IPv6-in-IPv4
          inet6 addr: ::88.195.194.203/128 Scope:Compat
          inet6 addr: 2001:2003:c3c2:cbcb::1/56 Scope:Global
          UP RUNNING NOARP  MTU:1280  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:101 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:7404 (7.2 KiB)

 

 

-> Pitäisi olla Sonera 6rd:ssä /64 prefixi... eli 

2001:2003:c3c2:cbcb::1/64

 

 Itselläni tuotti ongelmia tämä reititys... koska ei molemmissa interfacessavoi olla sama prefix tai osoitte. 

 

br-lan    Link encap:Ethernet  HWaddr 64:66:B3:FA:1D:80
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6666:b3ff:fefa:1d80/64 Scope:Link
          inet6 addr: 2001:2003:c3c2:cbcb::1/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:23235 errors:0 dropped:0 overruns:0 frame:0
          TX packets:29349 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2088398 (1.9 MiB)  TX bytes:34122364 (32.5 MiB)

Tällä hetkellä minulla toimii ainakin omassa Linuxissani /64 prefixillä osoitteisto 6rd interfacessa ja lanissa /65 prefix...  

 

Esim jos laittaisit /65 prefixin  br-lan interfaceen

 

 

2001:2003:c3c2:cbcb:a::1/65

 

Työasemille sitten esim näin

 

2001:2003:c3c2:cbcb::2/65

ja gw on tietenkin. Kokeile toimiiko näin. Dhcpv6 kylläkin haluaa tuon /64 prefixin verkon että sitten pitää olla staattiset. Itse en ole keksinyt parempaa ratkaisua.

 

 


Tuo /56 tulee suoraan Soneran DHCP palvelimelta..

 

Kuvankaappaus Asukseksta, jossa se toimii.

Sieppaa_asus.JPG

0 tykkäystä
Highlighted
Kunniajäsen
Rekisteröitynyt: ‎26-12-2013
Kirjoituksia: 4 399
4/9

Vs: Soneran 6rd IPv6 & sen toteutus OpenWRT:ssä

Täh... jaahas... pitääpä kokeilla itselläkin...

 

Katos... ainakin toimii tuo /56 prefixillä...

 

Onkos kukaan konffannut DHCPv6 relaytä IPv6:lla?

 

isc-dhcp-relay on ollut IPv4

0 tykkäystä
Highlighted
Kunniajäsen
Rekisteröitynyt: ‎26-12-2013
Kirjoituksia: 4 399
5/9

Vs: Soneran 6rd IPv6 & sen toteutus OpenWRT:ssä

Helpotin elämääni ja kytkin DHCPv6 palvelimen samaan verkkoon.

0 tykkäystä
Highlighted
Kommentaattori
Rekisteröitynyt: ‎27-12-2014
Kirjoituksia: 59
6/9

Vs: Soneran 6rd IPv6 & sen toteutus OpenWRT:ssä


@olkitu kirjoitti:

Helpotin elämääni ja kytkin DHCPv6 palvelimen samaan verkkoon.


 

Milläs toteutit?

 

Jostain joku vanha kone ja siihen kaks verkkokorttia vai? Hymiö Erittäin onnellinen

0 tykkäystä
Highlighted
Kunniajäsen
Rekisteröitynyt: ‎26-12-2013
Kirjoituksia: 4 399
7/9

Vs: Soneran 6rd IPv6 & sen toteutus OpenWRT:ssä

Itselläni siis DHCP palvelin virtuaalipalvelimena ja eri vlanissa kuin kotiverkkoni. Helppo oli vain kytkeä samaan verkkoon kun on trunk portti ja lisätä IPv6 osoite. Fyysisessä koneessa on kaksi verkkokorttia toki ja reitittimessäni.

0 tykkäystä
Highlighted
Kommentaattori
Rekisteröitynyt: ‎27-12-2014
Kirjoituksia: 59
8/9

Vs: Soneran 6rd IPv6 & sen toteutus OpenWRT:ssä

Aa, okei. Mikäs reititin sulla sitten oikein on käytössä, joss siinä on trunk portti? Hymiö Erittäin onnellinen

 

Itse viritin Asuksen RT-N56U purkkiin OpenWRT:n kun Asuksen omalla on jtn häikkää niin pingi on usein 300 vaikka normisti on 10ms.

 

Eikä ollut vaikea edes conffata vaan yllättävän helppoa itseasiassa.

 

Tässä tuli kyllä tämmöinen löyty tehtyä:

IPv6_speed

0 tykkäystä
Highlighted
Kunniajäsen
Rekisteröitynyt: ‎26-12-2013
Kirjoituksia: 4 399
9/9

Vs: Soneran 6rd IPv6 & sen toteutus OpenWRT:ssä

Linux serveri reitittimenä. Omani verkko on reilusti monimutkaisempi kuin tavallinen kotiverkko.

 

Itsellänikin on Asus RT-N56U mutta tällä hetkellä ihan Asuksen oma kun pääasiassa toimii WLAN tukiasemana. 

 

Tuo ipv6-test.com pitäisi saada Suomeen, testi turhan kaukana. Voisin kysellä jos saisi tuon API:n. 100/100 yhteys kuidulla mutta testissä jää reilusti alle.

 

b4846de0b8f21f09fc051c34d62ca985.png

0 tykkäystä